FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática FLASH
________________________________________________________ Escola Técnica Machado de Assis Imprensa 1 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática Sumário 1. O Ambiente do Flash ....................................................................................................4 1.1 Menu ..............................................................................................................................5 1.2 Barra de Ferramentas...................................................................................................5 1.3 Stage .............................................................................................................................8 1.4 Frames e Keyframes.....................................................................................................9 1.5 Layers ..........................................................................................................................10 1.6 Salvando o Filme ........................................................................................................10 1.7 Exportando o Filme.....................................................................................................11 2.Trabalhando com Textos..............................................................................................12 2.1 Links e outros Recursos ............................................................................................12 2.2 Filtros ..........................................................................................................................13 2.2.1 Drop Shadow ...........................................................................................................13 2.2.2 Blur ...........................................................................................................................13 2.2.3 Glow ..........................................................................................................................14 2.2.4 Bevel .........................................................................................................................14 2.2.5. Gradient Glow .........................................................................................................14 2.2.6 Gradient Bevel .........................................................................................................14 2.2.7 Adjust Color .............................................................................................................14 3 Trabalhando com Desenhos ........................................................................................16 3.1 Linhas ..........................................................................................................................17 3.2 Caneta .........................................................................................................................17 3.3 Círculos e Ovais .........................................................................................................18 3.4 Quadrados, Retângulos e Polígonos.........................................................................18 3.5 Lápis ............................................................................................................................19 3.6 Pincel ...........................................................................................................................19 3.7 Transformando um Desenho .....................................................................................20
________________________________________________________ Escola Técnica Machado de Assis Imprensa 2 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática 3.8 Balde de tinta, tinteiro e gradiente ............................................................................21 3.9 Conta­gotas e Borracha .............................................................................................23 4 Símbolos.........................................................................................................................24 5 Animação........................................................................................................................24 5.1 Animação Quadro a Quadro ......................................................................................24 5.2 Tweening Motion ........................................................................................................25 5.4. Morph .........................................................................................................................26 5.5. Efeito Mask ................................................................................................................26 5.6. Motion Guide..............................................................................................................29 5.7. Onion Skin .................................................................................................................31 6 Botões............................................................................................................................32 6.1. Editar o botão ............................................................................................................32 6.2. Criando uma Ação para o Botão ..............................................................................32 6.2.2. Eventos de clipe .....................................................................................................33 6.2.3. Eventos de quadro .................................................................................................33
________________________________________________________ Escola Técnica Machado de Assis Imprensa 3 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática 1. Conhecendo o Flash 1.1 O Ambiente do Flash A Página Inicial é exibida quando carregamos o programa. Através dela é possível abrir um documento, criar um documento, criar novos documentos, usar templates (“modelos de documentos”), entre outros. Esses mesmos comandos também estão disponíveis na Barra de Menu. Na coluna da esquerda podemos abrir um projeto existente utilizando o botão “Open”. Na coluna do meio podemos iniciar nossos projetos. Na coluna da direita temos as opções de modelos de aplicações Flash. Ao clicar em Flash Document ele mostrará a área composta por diversas janelas e opções.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 4 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática 1.2 Menu O menu contém os seguintes recursos: ü File: comandos de abrir (Open), fechar (Close), criar (New), salvar (Save), publicar (Publish), imprimir (Print), exportar (Export) e importar (Import) filmes e outros elementos. ü Edit: comandos para desfazer/refazer (Undo/Redo), copiar (Copy), colar (Paste), Cortar (Cut), duplicar (Duplicate) e selecionar tudo (Select all). Há também comandos de manipulação de frames (item Timeline), como copiar (Copy Frames) cortar (Cut Frames) e colar frames (Paste Frames), editar símbolos (Edit Symbols), editar objetos selecionados (Edit Selected), configurar as preferências do programa (Preferences), customizar a barra de ferramentas (Customize Tools Panel), criar mapeamento de fontes (Font Mapping) e configurar as teclas de atalho para o programa (Keybord Shortcuts). ü View: recursos de visualização do filme, como zoom (Zoom in, Zoom Out e Magnification), modos (Preview Mode), réguas (Rulers), grades (Grid), guias (Guide), entre outros. ü Insert: comandos para inserir elementos no filme, como frames, layers, keyframes (item Timeline), novas cenas (Scene), criação de símbolos (New Symbol) e efeitos da Linha do Tempo (Timeline Effects). ü Modify: comandos para modificar o documento (Document) como dimensões do filme, cor de fundo, título, entre outros. Podemos converter um símbolo (Convert to Symbol), trabalhar com bitmap (Bitmap), símbolos (Symbol), shapes (Shape) e objetos combinados (Combine Objects), além de poder trabalhar com a Linha do Tempo (Timeline), editar ou remover efeitos da timeline (Timeline Effects), transformar e rotacionar objetos (Transform), mudar a ordem de empilhamento (Arrange), alinhar (Align) e criar grupos (Group) ou desagrupar (Ungroup). ü Text: comandos referentes ao texto, como tipo (Font), tamanho (Size) e estilo de fonte (Style), alinhamento (Align), espaçamento entre as letras (Letter Spacing), criação de textos rolantes (Scrollable) e verificação da ortografia (Check Spelling). ü Commands: gerencia comandos para se usar com o Flash. Os comandos são pequenos aplicativos desenvolvidos por terceiros para se utilizar como o programa e muitas vezes facilitam o trabalho do desenvolvedor, pois podem aplicar um determinado recurso de forma automática. ü Control: comandos ligados ao controle do filme (para tocar – Play, parar – Stop, rebobinar – Rewind). Também é possível testar o filme com Test Movie. ü Window: comandos referentes às janelas, menus e painéis do programa. ü Help: contem informações sobre o Fhash 8, tópicos de ajuda, tutoriais e exemplos de arquivos feitos no programa. 1.3 Barra de Ferramentas
________________________________________________________ Escola Técnica Machado de Assis Imprensa 5 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática A Barra de Ferramentas está dividida em quatro seções: Tools (Ferramentas), View (Visualização), Colors (Cores) e Options (Opções). Permite fazer a seleção de elementos em seu filme. Além disso, essa ferramenta serve para redimensionar e arrastar elementos no stage (palco). Os objetos no Flash diferenciam contorno de preenchimento então se você clicar no meio de um objeto você apenas selecionará o preenchimento. Para poder selecionar ambos é necessário um duplo clique ou simular um contorno sobre ambos com a ferramenta seta. Permite fazer a seleção, arraste e redimensionamento de elementos. Permite a transformação e redimensionamento de um elemento criando deformações e distorções. Ao clicar sobre ela, será mostrado alças de dimensão em volta de seu objeto. Na parte de Options da caixa de ferramentas ele mostra as opções da ferramenta. A primeira opção é a “Rotate and Skew”, que permite rotacionar e inclinar a ferramenta. A segunda opção “Scale” permite dimensionar a forma selecionada. Se redimensionar seu objeto com a tecla ALT pressionada ao dimensionar para um lado ele faz a mesma dimensão para o outro lado. A terceira opção é a opção Distort que permite distorcer seu objeto em perspectiva. A última opção é a Envelope que vai permitir editar o objeto com curvas de bezier. Permite a utilização de um gradiente ou de um bitmap como preenchimento. Desenha uma linha Permite selecionar uma área usando o laço. Caneta. Permite desenhar linhas e curvas. Escreve um texto. Desenha um círculo ou oval. Desenha um retângulo ou outras formas quando pressionamos o botão esquerdo do mouse. Lápis. Utilizado para desenhar na área de trabalho. Usado para preencher (colorir) áreas. Efetua a pintura das bordas. Balde de pintura. Pinta o interior da figura.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 6 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática Efetua a captação da tonalidade de cor de um determinado elemento. Apaga um conteúdo desenhado no palco. O ícone chamado mão (Hand Tool) serve para movimentar o palco para qualquer posição sem que interfira no posicionamento dos elementos já inseridos. É utilizado para o desenvolvedor visualizar melhor seu arquivo. O segundo ícone, a lupa (Zoom Tool), serve para aumentar o zoom para uma melhor visualização. Para voltar para um tamanho menor ou um outro qualquer, use a caixa de seleção de porcentagem que existe no lado superior direito da timeline. Você pode criar um tamanho personalizado digitando um valor na caixa de seleção. Define a cor da linha ou da borda. Define a cor do preenchimento. 1.4 Timeline A Linha do tempo é utilizada na criação de animações. Através dela podemos definir qual será a mudança e/ou caminho a ser especificado pelo objeto do filme. Podemos través de a linha tempo utilizar camadas para melhor agrupamento e movimento dos objetos. Na parte superior da timeline fica o nome do arquivo. Quando o arquivo ainda não está salvo recebe o nome de Untitled­1, sendo que o número 1 pode mudar de acordo com o numero de arquivos não­salvos criados. Na timeline encontramos as opções de visualização de camadas: mostrar / ocultar, bloquear / desbloquear e visualizar somente traços: .
________________________________________________________ Escola Técnica Machado de Assis Imprensa 7 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática Quando trabalhamos com animações, sempre consideramos o fator “tempo”. As animações irão correr conforme o tempo for passando. O tempo, no flash, é medido através da quantidade de frames, também chamados de quadros, presentes na timeline. Portanto, geralmente quanto maior a quantidade de frames, mais longa será a animação. Os frames da timeline são representados pelos quadradinhos brancos. Quando um quadro possui um objeto ele apresenta uma bolinha preenchida, quando o mesmo apresentar uma bolinha vazada é um quadro vazio e quando o mesmo apresentar um “a” significa que nesse quadro temos ações (ações são blocos de códigos dentro de nossa animação). As layers são as camadas do filme. Podemos trabalhar com várias camadas simultaneamente. Dessa maneira uma camada não interfere na outra. Lembre­se que a camada de cima exibida na timeline sempre estará acima da camada mais abaixo. No final do empilhamento de camadas temos os botões que nos permitem criar as camadas do Flash. Criar uma camada normal, criar uma camada GUIA, criar uma pasta (permite armazenar camadas dentro delas e no final da linha excluir uma camada). Na parte de baixo temos a velocidade de nosso filme (12fps), 12 Frames per second (Quadros por segundo). Significa que nosso filme apresenta 12 quadros de animação por segundo. Esse valor por ser alterado conforme a velocidade que desejamos que o filme seja reproduzido. 1.5 Stage O stage também é conhecido como palco. É nesse local onde se deve determinar o posicionamento e efetuar a inserção de elementos, criar desenhos, escrever textos, entre outros. É o local de trabalho do programa. Você pode definir as propriedades de sua tela, como tamanho, cor e velocidade ao qual o seu filme vai trabalhar. Estas propriedades podem ser alteradas através da barra de propriedades abaixo de sua tela.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 8 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática 1.6 Frames e Keyframes Para inserir frames na timeline, clique no frame desejado e pressione a tecla de atalho F5 ou clique com o botão direito do mouse e, em seguida, clique em Insert Frame. Outra maneira é ir ao menu Insert – Timeline e clicar na opção Frame. A maneira mais rápida e fácil é usar a tecla de atalho. Um frame inserido em um layer conterá o mesmo conteúdo do frame a partir do qual ele foi adicionado. Se o frame não possui nenhum conteúdo no stage, aparecerá um círculo branco dentro desse frame na timeline, significando que esse frame está vazio. Quando um frame possui algum conteúdo, o círculo passa a ser preto. Para inserir um Keyframe, basta clicar no frame onde quer fazer a inserção e pressionar a tecla F6 ou ir ao menu Insert­ Timeline­ Keyframe, ou ainda clicando com o botão direito do mouse e, em seguida, em Insert Keyframe. Se houver a necessidade de inserir um Keyframe vaziu, clique na opção Insert Blank Keyframe. O Keyframe é utilizado para alterar um conteúdo de um determinado frame sem alterar os frames anteriores. Para apagar um frame, clique com o botão direito do mouse sobre o frame que quer deletar e, em seguida, na opção Remove Frames. Para retirar um Keyframe, faça o mesmo procedimento, porém, clique na opção Clear Keyframe.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 9 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática 1.7 Layers Os layers, ou camadas, permitem a construção de várias animações, efeitos ou inserção de elementos simultaneamente no filme, sem que um elemento interfira em outro, exceto quando houver propositalmente a sobreposição de um elemento em outro. Para inserir camadas, clique no ícone Inserir Layer presente na timeline. Um novo layer é inserido na parte superior em relação ao layer que foi criado. Após inserir um novo layer, você pode renomeá­lo facilitando a identificação do conteúdo desse layer. Para fazer isso é só clicar duas vezes no nome da layer e em seguida digitar o novo nome. Se quiser apagar um layer e consequentemente todo o seu conteúdo, selecione o layer e clique no ícone de lixeira presente na timeline. Ao trabalhar com layer encontramos ainda os seguintes itens: ü Show/Hide all Layers: mostra ou esconde os layers. Pode ser usado quando o conteúdo de um layer estiver atrapalhando a visualização de outro durante o desenvolvimento de seus filmes. ü Lock/ Unlock all Layers: bloqueia ou desboqueia um layer. Quando o layer está bloqueado não poderá sofrer modificações em seu conteúdo. ü Show all Layers as Outlines: mostra apenas as linhas do conteúdo do layer, os preenchimentos não são mostrados. 1.8 Salvando o Filme Escolha a opção File – Save As. O arquivo salva terá a extensão .fla indicando que pode ser aberto e editado pelo Flash.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 10 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática 1.9 Exportando o Filme Para exportar um filme, vá ao Menu File – Export – Export Movie. Irá abrir uma nova janela para você digitar o nome do arquivo e selecionar o diretório onde quer exportar seu arquivo .swf. Exercício 1: ­ Abra um arquivo novo no Flash ­ Defina as características do seu filme. Para isso vá ao menu Modify – Document. A seguinte tela será exibida: ­ Você pode dar um título ao documento, alterar as dimensões, a cor do plano de fundo, que por padrão é branca e a velocidade do filme, que por padrão é 12. ­ Feito isso desenhe um círculo de cor qualquer no palco. ­ Clique no frame 25 da timeline e aperte a tecla F5. Assim você estará criando um layer com 25 frames, ou seja, uma camada com 25 quadros. ­ Novamente no frame 25 aperte F6. Assim você estará criando um Keyframe no frame 25, ou seja, criando um quadro chave e levando o conteúdo criado no frame 1 para o frame 25. ­ No frame 25 clique no círculo criado e modifique a cor. ­ Clique no frame 1 e nas propriedades, no item Tween, selecione a opção Shape. Agora é só executar a animação e visualizar o resultado.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 11 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática 2. Trabalhando com Textos Para trabalhar com textos no Flash é usada a ferramenta Text: . No painel de propriedades irão estar disponíveis as propriedades do texto. Nesse painel é possível alterar o tipo de fonte, o tamanho, espaçamento, cor, estilo, alinhamento, formatação, orientação, posição e dimensão. 2.1 Links e outros Recursos É possível transformar um texto em um link. Dessa maneira, é necessário digitar o link no campo URL Link presente no painel Properties. Existem ainda Targets disponíveis: ü _blank: abre o link em uma nova janela do navegador. ü _parent: abre o link retirando apenas o conjunto de framesets que a página contiver. Essa opção só funciona se houver vários conjuntos de framesets. ü _self: abre o link no mesmo frame ou janela do navegador que a página estiver. ü _top: abre o link na mesma janela do navegador retirando todos os frames e framesets que a página tiver. Outros recursos que podem ser aplicados em textos: ü Use Device Fonts: nesse caso as fontes utilizadas são do computador do usuário. Normalmente é usado por versões anteriores do Flash. ü Bitmap Text (no anti­alias): transforma os textos digitados no filme em imagens suavizadas. Essa opção geralmente produz filmes mais pesados devido à essa renderização.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 12 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática ü Anti­alias for Animation: essa opção é bastante utilizada se o texto estiver em movimento no stage. ü Anti­alias for Readability: essa opção é utilizada em textos estáticos (Static Text). ü Custom Anti­Alias: essa opção permite ao desenvolvedor criar seu próprio anti­alias. 2.2 Filtros Após digitar o texto, você pode aplicar filtros a ele clicando na aba filtros do painel de propriedades. Nos filtros você encontra as seguintes opções: 2.2.1 Drop Shadow Esse filtro produz uma sombra no elemento. Suas configurações são: ü Blur X e Blur Y: produz o embaçamento nas direções X e Y simultaneamente. Quanto maior o valor, maior a área do efeito. ü Strength: define a intensidade do efeito. ü Quality: define a qualidade do efeito (Low­ baixa, Medium – Média e High – alta). ü Color: define a cor da sombra. ü Angle: define o grau de aplicação do efeito. ü Distance: define a distância do efeito em relação ao texto. ü Knockout: produz um efeito tornando a palavra vazada. ü Inner Shadow: gera a sombra internamente no texto. ü Hide Object: esconde o elemento, mostrando apenas o efeito aplicado. 2.2.2 Blur Esse filtro produz uma espécie de embaçamento no elemento. Suas configurações são: ü Blur X e Blur Y: produz o embaçamento nas direções X e Y simultaneamente. Quanto maior o valor, maior a área do efeito.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 13 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática ü Quality: define a qualidade do efeito (Low­ baixa, Medium – Média e High – alta). 2.2.3 Glow Esse filtro produz uma espécie de embaçamento produzido nos contornos do elemento. Suas configurações são: ü Blur X e Blur Y: produz o embaçamento nas direções X e Y simultaneamente. Quanto maior o valor, maior a área do efeito. ü Strength: define a intensidade do efeito. ü Quality: define a qualidade do efeito (Low­ baixa, Medium – Média e High – alta). ü Color: define a cor do contorno. ü Knockout: produz um efeito tornando a palavra vazada. ü Inner Glow: gera o efeito Glow internamente no texto. 2.2.4 Bevel Esse filtro produz um relevo no elemento. Suas configurações são: ü Blur X e Blur Y: produz o embaçamento nas direções X e Y simultaneamente. Quanto maior o valor, maior a área do efeito. ü Strength: define a intensidade do efeito. ü Quality: define a qualidade do efeito (Low­ baixa, Medium – Média e High – alta). ü Shadow: define a cor da iluminação do efeito. ü Highlight: define a cor da sombra. ü Angle: define o grau de aplicação do efeito. ü Distance: define a distância do efeito em relação ao texto. ü Knockout: produz um efeito tornando a palavra vazada. 2.2.5. Gradient Glow Esse filtro produz efeito de Glow com gradiente no elemento. 2.2.6 Gradient Bevel Esse filtro produz efeito Bevel com gradiente no elemento. 2.2.7 Adjust Color Esse filtro permite ajustar a cor do elemento. As opções são: ü Brightness: ajusta o nível de brilho do elemento. ü Contrast: ajusta o nível de contraste do elemento. ü Saturation: ajusta o nível de saturamento do elemento.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 14 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática ü Hue: ajusta o nível de tonalidade do elemento. Exercício 2 ­ Crie um novo arquivo. ­ Escreva no palco seu primeiro nome. ­ Utilize a fonte Verdana, em negrito, cor vermelha e coloque a orientação do texto como sendo Vertical, Left to Right. ­ Abra o painel Filters e aplique o filtro Drop Shadow. Configure: ü Blur X e Blur Y: 7 ü Strength: 150%. ü Quality: High – alta. ü Color: preto. ü Angle: 116. ü Distance: 4. ü Marque a opção Knockout ­ Veja o resultado. ­ Agora vamos combinar o filtro Bevel ao anterior. ­ Abra o painel Filters e aplique o filtro Bevel (o anterior fica, você está apenas acrescentando mais um filtro). ­ Configure como: ü Blur X e Blur Y: 5 ü Strength: 100%. ü Quality: High – alta. ü Shadow: azul. ü Highlight: amarelo. ü Angle: 45. ü Distance: ­10. ü Type: full. ­ Veja o resultado. O texto conterá um sombreado com duas cores. Os filtros permitem a criação de inúmeros efeitos interessantes.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 15 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática 3 Trabalhando com Desenhos Os desenhos no flash são feitos através da Barra de Ferramentas. Qualquer ferramenta de desenho no Flash tem suas propriedades exibidas no painel Properties. Algumas delas podem ficar desabilitadas ou não serem exibidas dependendo da ferramenta utilizada. ü W: define o tamanho ou a largura do elemento. ü H: define a altura do elemento. ü X: define a posição do eixo X do elemento. ü Y: define a posição do eixo y do elemento. ü : define a cor do elemento. ü : define a espessura da linha ou borda ü : define a cor do preenchemento. ü : auxilia no encaixe das linhas na borda. ü : define o estilo da linha. ü ü ü : define o tipo da escala do elemento quando executado pelo Flash Player. : especifica o estilo da borda customizado. : especifica o valor quando a ligação do tipo Miter for escolhida em Join. ü : define o tipo de fechamento de uma linha. ü : define o tipo de ligação entre uma linha e outra. As opções são: Miter (pontiagudo), Round (arredondado) e Bevel (cortada).
________________________________________________________ Escola Técnica Machado de Assis Imprensa 16 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática 3.1 Linhas A ferramenta Line Tool é utilizada para desenhar linhas e traçados no Flash. No painel Properties, escolha o tipo da linha e demais propriedades, como cor, tamanho, entre outros. Para alterar a curvatura de uma linha, selecione a ferramenta Arrow Tool e, com o botão esquerdo do mouse, clique sobre uma área da reta, mantenha o botão pressionado e arraste ligeiramente para a formação da curva. 3.2 Caneta A ferramenta Pen Tool é utilizada para desenhar retas e curvaturas no Flash. Para utilizar você deve clicar em um ponto inicial e depois em um ponto final. No caso de curvas, é necessário clicar para definir um pinto inicial. Solte o ponteiro do mouse. Em seguida, deve­se clicar em outro ponto e manter o botão pressionado, arrastando até formar a curva desejada.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 17 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática 3.3 Círculos e Ovais Os círculos e ovais são desenhados através da ferramenta Oval Tool . Para utilizar, selecione a ferramenta, clique com o botão esquerdo do mouse, mantenha­o pressionado e arreste para formar o círculo ou oval. Para fazer circunferências usar shift ao mesmo tempo que se desenha. Antes de desenhar deve escolher a espessura do contorno, o tipo de linha, a cor do contorno e do preenchimento. Estas propriedades podem ser alteradas posteriormente no painel propriedades mediante a seleção do elemento. 3.4 Quadrados, Retângulos e Polígonos Os quadrados e retângulos podem ser desenhados com a Rectangle Tool . Para desenhar, ativar a ferramenta e arrastar o mouse no palco. Para fazer quadrados usar shift ao mesmo tempo que se desenha. Antes de desenhar deve escolher a espessura do contorno, o tipo de linha, a cor do contorno e do preenchimento. Estas propriedades podem ser alteradas posteriormente no painel propriedades mediante a seleção do elemento. Para criar quadrados com as pontas arredondadas, clique no ícone Set Corner Radius presente em Options, na parte inferior da barra de ferramentas. Ao clicar nessa opção uma janela é aberta para digitar o valor do Corner Radius, ou seja, raio da curvatura. Mantendo o botão esquerdo pressionado temos a opção de desenhar polígonos. Com essa ferramenta podemos fazer diversos tipos de polígonos. Clique no botão Options presente no painel Properties.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 18 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática Encontramos as opções Style (define o tipo de polígono, que pode ser polígono ou estrela), Number of Sides (especifica a quantidade de lados que o polígono irá conter) e Star point size (especifica o tamanho do ponto quando for desenhar estrelas). 3.5 Lápis A ferramenta de lápis permite fazer traçados no Flash. É uma ferramenta usada para desenhar a mão livre. Ela cria apenas contornos e tem as seguintes opções: Esta ferramenta tem opções: Angular Curvo Livre 3.6 Pincel A ferramenta de Pincel permite pintar um elemento. O tipo de pintura de ser definido em Options.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 19 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática Normal ­ pinta sobre todos os objetos sem limitações. Fills ­ Não pinta sobre contornos. Behind ­ pinta atrás em zonas em branco Selection ­ pinta em zonas selecionadas e com preenchimento. Inside ­ pinta em zonas que já têm preenchimento. 3.7 Transformando um Desenho Com essa ferramenta é possível transformar um desenho. Mantendo a tecla SHIFT pressionada o redimensionamento será proporcional (o que é recomendado!). Ao clicar sobre ela, será mostrado alças de dimensão em volta de seu objeto. Na parte de Options da caixa de ferramentas ele mostra as opções da ferramenta. A primeira opção é a “Rotate and Skew”, que permite rotacionar e inclinar a ferramenta. A segunda opção “Scale” permite dimensionar a forma selecionada. Se redimensionar seu objeto com a tecla ALT pressionada ao dimensionar para um lado ele faz a mesma dimensão para o outro
________________________________________________________ Escola Técnica Machado de Assis Imprensa 20 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática lado. A terceira opção é a opção Distort que permite distorcer seu objeto em perspectiva. A última opção é a Envelope que vai permitir editar o objeto distorcendo e criando efeitos interessantes. 3.8 Balde de tinta, tinteiro e gradiente A ferramenta Tinteiro permite pintar a cor de contorno dos objetos. Basta selecioná­la e aplicar a cor desejada diretamente na linha de contorno de seus objetos. Ao lado dela temos a ferramenta Balde de Tinta que permite modificar a cor de preenchimento dos objetos. O Flash possui, para preenchimento as cores, a paleta WEBSAFE e também alguns gradientes existentes. Na caixa de opções também podemos definir como deve ser aplicado o preenchimento, em todo o objeto, ou com lacunas. Quando se trabalha com preenchimentos é necessário que se chame à paleta Misturador de Cores. Nesta paleta podemos definir se o preenchimento será sólido, linear, radial ou bitmap. Podemos também atribuir a cor através de seu código RGB, ou hexadecimal, além de aplicar um canal Alpha. Na paleta “Color” a opção padrão inicial é Solid onde podemos definir as cores de contorno e preenchimento pela escolha da cor, códigos RGB e Hexadecimal. A opção Alpha define o grau de transparência da cor. Na opção TYPE temos como padrão SOLID, ao clicar nessa opção podemos
________________________________________________________ Escola Técnica Machado de Assis Imprensa 21 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática mudar para linear que aplicará ao objeto selecionado. Ao escolher opção SOLID , será mostrado na opção COLOR a barra de cores gradiente. Você pode observar que temos na opção gradiente duas alças de cores, para alterar a cor de qualquer uma das alças de gradiente, basta clicar sobre ela e escolher a cor desejada. Podemos acrescentar uma alça de gradiente a nossa paleta de cores, basta clicar entre uma delas para criar as outras alças de cores. Para retirar uma das alças basta apenas clicar sobre a alça, manter o mouse pressionado e arrastar para fora da linha. Essa ferramenta é utilizada para redimensionar áreas preenchidas com gradiente. Se você tiver uma imagem preenchida com gradiente, para alterar o gradiente podemos usar essa ferramenta. Ao selecionar o objeto com o gradiente e clicar na ferramenta ele vai mostrar uma alça quadrada e uma redonda em volta do gradiente.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 22 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática A alça quadrada permite aproximar / afastar as cores gradientes, a alça em círculo permite rotacionar o gradiente. Podemos também escolher a opção RADIAL que permite aplicar as mesmas opções do gradiente LINEAR. Podemos também definir a opção de gradiente e preencher nosso objeto com o balde de tinta. 3.9 Conta­gotas e Borracha A ferramenta conta­gotas permite capturar a cor de um objeto e aplicar dentro de outro, por exemplo, se você importar um bitmap para dentro do flash e depois desejar aplicar este bitmap como preenchimento de um objeto clique sobre o bitmap com o conta gotas, a ferramenta modifica­se imediatamente para o balde de tinta e você pode preencher onde desejar. A ferramenta ao lado o apagador funciona como uma borracha . No entanto, o cuidado ao apagar é necessário. Você pode utilizar as opções desta ferramenta : Erase Normal: apaga qualquer elemento desenhado no stage. Erase Fills: apaga somente o preenchimento. Erase Lines: apaga somente linhas e bordas. Erase Selected Fills: apaga somente o preenchimento selecionado. Erase Inside: apaga somente a área onde foi iniciado (dentro ou fora do desenho). Exercício 3 ­ Crie um novo arquivo. ­ Selecione a ferramenta Polygon Tool e desenhe um polígono com 9 lados. Escolha a linha em Stroke Style no painel Properties. ­ Deixe a borda do polígono com seis pontos. Para isso, selecione todo o polígono com a ferramenta Arrow Tool e, em seguida, no painel Properties mude o tamanho da borda e a cor.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 23 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática ­ Em seguida aplique um gradiente. ­ Faça experimentos rotacionando o objeto. 4 Símbolos Para podermos trabalhar com animações no FLASH é necessário que quase todos os elementos sejam convertidos para símbolos, pois é através de símbolos que podemos definir qual o seu comportamento: Os três símbolos do FLASH são Gráficos , Botões e Clipes de Filme . Você pode criar o objeto e depois convertê­lo em Símbolo ou através do menu Insert ­ Convert to Symbol. Para converter um objeto existente em símbolo basta apenas apertar a tecla de função F8. Gráfico: Este é o tipo mais básico de símbolo, pois ele é praticamente estático, embora possa receber ações para ele, é muito utilizado também dentro dos outros símbolos. Botão: Este símbolo pode receber valores diferentes para estado do botão, normal, ao rola sobre, pressionado e oculto, é muito utilizado para chamar ações. Clipe de Filme: Este tipo de símbolo permite que se crie um filme dentro do símbolo com a vantagem de que ele carrega todo o clipe de filme primeiro e mostra o mesmo no filme todo de uma vez. 5 Animação 5.1 Animação Quadro a Quadro Em animações Quadro a Quadro, criamos, manualmente, o que chamamos de keyframes. Utilizamos esse recurso para implementarmos efeitos de movimento aos desenhos. Quando se trabalhar com animação quadro a quadro não se converte os objetos em símbolos. Vários keyframes em seqüência produzem uma animação. As animações quadro a quadro são muito utilizadas para a criação de desenhos animados ou em casos que precisamos de muita precisão em um movimento, como por exemplo, um movimento facial.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 24 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática Exercício 4 ­ Para entendermos melhor este processo crie uma circunferência na sua área de desenho. Observe que ao desenhar o objeto no filme do Flash, no primeiro quadro aparece uma bolinha preta , mostrando que no quadro existe um objeto. ­ Para inserir uma instância deste mesmo objeto no próximo quadro, clique com o botão direito do mouse no próximo quadro e escolha Inserir Quadro Chave (tecla de atalho F6). Ele repete o mesmo símbolo. ­ Modifique a cor de seu símbolo. ­ Repita este processo até o quadro 12, alterando a cor de seu objeto a cada quadro. ­ Para testar aperte as teclas CTRL+ENTER, isso testa o seu filme e gera um arquivo com a extensão SWF. 5.2 Tweening Motion É usado para a criação de movimento. Você pode aplicar o Tweening Motion com um grupo, símbolo ou texto. Flash. Ele consiste em criar a movimentação quadro a quadro de um objeto, quando esse se movimenta de um ponto a outro. Regras: 1. É possível somente utilizar objetos, como: símbolo, agrupamento, texto e bitmap. 2. O objeto do frame final deve ser o mesmo do início. 3. Só podemos utilizar um objeto por layer. Exercício 5: ­ Comece um novo filme e cria uma circunferência com preenchimento ao seu gosto e transforme­a em um símbolo. ­ Crie um novo quadro no quadro 12 e mude a posição de sua circunferência. ­ Para podermos criar a interpolação de movimento podemos clicar com o botão direito no quadro 1 e escolher “Create Motion Tween”, ou podemos utilizar a barra de propriedades, clique no inicio de sua animação na Timeline (no caso no quadro 1) e na barra de propriedades na opção Tween coloque “Motion”. 5.3. Tweening Shape O efeito Tweening Shape é utilizado para criar interpolação entre uma forma e outra. Esse efeito é também conhecido como morphing. Regras: 1. Somente é possível utilizar objetos desagrupados.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 25 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática 2. Somente é possível utilizar um objeto por layer. 3. Não pode ser aplicado em símbolos, textos e Bitmaps. Exercício 6: ­ Crie um novo arquivo. ­ No layer 1 da timeline, clique no frame 20 e aperte F5 para criar um filme contendo 20 frames no total. ­ Clique no frame 1. Selecione a ferramenta Oval Tool e desenhe um círculo ou oval. ­ Clique no frame 20 e crie um Keyframe (F6). Nesse momento perceba que todo o seu círculo estará selecionado, Apague­o usando o Delete. ­ No lugar desenhe uma estrela de 5 pontas. ­ Clique no frame 1 e no painel Properties aplique o Tweening Shape. ­ Agora é só testar! 5.4. Morph Trata­se de um efeito onde um objeto se transforma em outro gradativamente. Exercício 7: ­ Crie um novo docimento. ­ Deixe o Layer 1 com 20 frames no total ­ Selecione a ferramenta Text Tool e digite o seu nome. ­ Selecione a palavra digitada e vá ao menu Modify – Break Apart. ­ Aplique novamente esse efeito. Como estamos trabalhando com uma palavra, é necessário aplicar duas vezes o comando. Na primeira vez o Break Apart quebra a palavra em letras e na segunda ele quebra cada letra em minúsculos pedaços. ­ Clique no frame 20 e crie um keyframe (F6). ­ Apague a palavra e digite outra no lugar. Como por exemplo, seu sobrenome. ­ Selecione a palavra digitada e aplique duas vezes o comando Break Apart. ­ Clique no frame 1. No painel Properties, selecione em Tween o item Shape. ­ Teste seu filme. 5.5. Efeito Mask As máscaras possibilitam a criação de efeitos interessantes, permitindo recortar o conteúdo de um layer e sobrepor para essa área recortada o conteúdo de outro layer, invertendo os conteúdos. Trabalhar com máscaras requer pelo menos duas camadas.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 26 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática Exercício 8: ­ Crie um novo filme. ­ Deixe o Layer 1 com 15 frames no total. ­ Crie o Layer 2 também com 15 frames ­ Renomeio o Layer 1 como retângulo e o Layer 2 como texto para facilitar a identificação. ­ Clique no frame 1 do layer texto e digite o seu nome no palco. ­ Clique no frame 1 do layer retângulo e desenhe um retângulo sem linha antes da primeira letra do texto: ­ Em seguida clique no frame 15 do layer retângulo e crie um Keyframe (F6). Aumente o retângulo para que ele sobreponha todo o texto: ­ Clique no frame 1 do retângulo e aplique o efeito Tweening Shape no painel Properties. ­ Clique com o botão direito do mouse em cima do nome do layer texto e clique em Mask.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 27 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática ­ Pronto! Veja o resultado. Repare que após a aplicação do Mask, os layers ficam bloqueados, ou seja, com o ícone do cadeado ativado. Se os dois layers não estivem bloqueados, o efeito Mask não funcionará. Se houver a necessidade de mexer em algum layer que contenha o Mask, desative o cadeado e após feita a modificação bloqueie­o novamente. Com isso o efeito Mask voltará a funcionar. Faça o próximo exercício para ver a palavra estática com o fundo se movendo: Exercício 9: ­ Crie um novo filme contendo 2 layers com 20 frames cada um. ­ Renomeie o layer de cima, chamando­o de texto, e o layer de baixo, chamando­o de efeito. ­ No layer texto, clique no primeiro frame e insira um texto no stage, como seu nome completo, por exemplo. Aplique a cor azul escuro na fonte. ­ Clique no layer efeito, e no frame 1 insira um retângulo com cor e borda preta cobrindo todo o texto escrito. Deixe o retângulo um pouco maior que o texto:
________________________________________________________ Escola Técnica Machado de Assis Imprensa 28 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática ­ Selecione, na barra de Ferramentas, em color, no item Fill Color (balde de tinta), uma cor clara e, em seguida, clique no frame 1 do layer efeito e pinte com o pincel dentro desse retângulo preto, uma faixa antes da primeira palavra do texto. Essa cor será a que correrá dentro da frase durante o efeito Mask: ­ Clique no último frame do layer Efeito e crie um Keyframe (F6). Se todo o conteúdo aparecer selecionado aperte a tecla ESC para desmarcar. Nesse último frame, selecione a faixa de cor clara e arraste­a para a outra extremidade do texto. ­ O local da primeira mancha ficou em branco. Com o balde de tinta, preencha­a com cor preta. ­ Clique no primeiro frame do layer efeito e crie um tweening do tipo Shape. ­ Clique com o botão direito do mouse sobre o nome do layer texto e aplique o Mask. ­ Agora é só testar! 5.6. Motion Guide O Motion Guide é também chamado de guia de movimento. Essa técnica indica a trajetória que um determinado símbolo irá percorrer durante a animação no stage. A diferença básica entre um Motion Guide e um Tweening é que este último é usado em trajetórias lineares, já o Motion Guide pode ser usado para criar trajetórias mais complexas, como retas e curvas ao mesmo tempo.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 29 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática Exercício 10 ­ Crie um novo filme com um layer contendo 30 frames. ­ Desenhe um círculo no palco. ­ Selecione o círculo e tecle F8 para criar um símbolo, do Tipo Gráfico. ­ Certifique­se que a opção Snap to Objects esteja marcada. Para isso, verifique o menu View – Snapping – Snap to Objects. ­ Clique no frame 30 e crie um keyframe (F6). Selecione a bola e arraste­a para uma posição diferente. ­ Clique no lápis presente na frente do nome da layer 1. Isso marcará todos os frames desse layer. Clique com o botão direito do mouse sobre o nome do layer e escolha a opção Add Motion Guide. ­ Automaticamente é criado um novo layer chamado Guide: Layer1, ou seja, Guia do Layer 1. ­ Clique no frame 1 do Guide: Layer1. Selecione a ferramenta Pencil Tool (lápis) e nas opções que aparecerem escolha o tipo Smooth. Isso fará com que seu traçado seja suavizado. Use uma cor escura se o fundo do palco for branco. ­ Desenhe no palco a trajetória que a bola irá percorrer. ­ Clique no frame 1 do layer 1, selecione a ferramenta Arrow Tool e posicione a bola exatamente sobre o começo da linha. Uma dica é posicionar o ponteiro do mouse sobre o ícone de círculo vazio na parte central do seu desenho. Durante o arrante, você perceberá que o elemento se encaixa na linha como se estivesse atraído por ela.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 30 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática ­ Clique no frame 30 da layer 1 e arraste a bola para o final da trajetória. ­ Clique no frame 1 da layer 1 e no painel Properties, aplique o tweening do tipo Motion. Marque também a opção Oriente to pash. ­ Agora é só testar seu filme. 5.7. Onion Skin Onion Skin, ou casca de cebola, é formado por um conjunto de várias camadas. Quando se cria uma animação muitas vezes temos a necessidade de ficar indo e vindo através dos quadros para termos uma idéia melhor de como está ficando a animação, o que causa uma grande perca de tempo. Mas para facilitar todo este processo o FLASH possui um processo chamado Onion Skin. Com ele podemos editar o quadro atual enquanto observamos o quadro que está logo abaixo dele ou até mesmo editar diversos quadros simultaneamente. O quadro atual aparece com as cores normais, enquanto os quadros anteriores aparecem com as cores apagadas, como se estivéssemos sendo vistos através de uma folha de papel vegetal. Somente o quadro atual pode ser modificado, os quadros apagados não podem ser alterados. Vamos fazer um exercício para aprender como usar esse recurso. Exercício 11: ­ Crie uma layer com 20 frames. ­ Clique no frame 1. No palco escreva seu nome. ­ Clique no frame 20 e crie um Keyframe (F6). Selecione seu nome e arraste para uma posição diferente no palco. ­ Clique no frame 1. No painel Properties, escolha em Tween o tipo Motion. Escolha em Totate o tipo CW e em Times digite 1. ­ Clique no nome do Layer 1. Com isso você está selecionando todos os frames do layer. Em seguida, vá em menu Edit – Timeline – Copy Frames. ­ Crie um novo layer, o Layer 2. Clique no frame 3 do layer 2, crie um keyframe (F6) e vá ao menu Edit – Timeline ­ Paste Frames.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 31 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática ­ Crie um novo layer, o layer 3. Clique no frame 6 do layer 3 e crie um keyframe (F6). Vá novamente em Edit – Timeline ­ Paste Frames. ­ Teste seu filme. 6 Botões Os botões são fundamentais para criar interações no seu arquivo. Após criar um botão são necessárias duas etapas: editar o botão e criar uma ação para o botão. 6.1. Editar o botão Os botões são clipes de filme interativos compostos por quatro quadros. Quando você seleciona o comportamento de botão para um símbolo, o Flash cria uma Linha de Tempo com quatro quadros. Os primeiros três exibem os três estados possíveis do botão, enquanto o quarto defina sua área ativa. Na realidade, a Linha de Tempo não é reproduzida, simplesmente reage ao movimento do ponteiro às ações, passando para o quadro apropriado. Cada quadro na Linha de Tempo de um símbolo de botão tem uma função específica: ü Up: estado inicial do botão. ü Over: estado quando o ponteiro do mouse passa sobre o botão. ü Down: estado no momento em que o botão é clicado. ü Hit: define a área do clique de um botão. Para editá­lo é preciso definir dos quadro estados. 6.2. Criando uma Ação para o Botão
________________________________________________________ Escola Técnica Machado de Assis Imprensa 32 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática 6.2.1. Eventos de mouse e teclado Quando o usuário interage com seu aplicativo ou arquivo SWF, ele ativa eventos de mouse e teclado. Por exemplo, quando ele rola sobre um botão, ocorre o evento Button.onRollOver ou on(rollOver); quando ele clica em um botão, o evento Button.onRelease é ativado; se uma tecla do teclado for pressionada, o evento on(keyPress) ocorrerá. Você pode criar um código em um quadro ou anexar scripts a uma instância para manipular esses eventos e adicionar toda a interatividade desejada. 6.2.2. Eventos de clipe Em um clipe de filme, você pode reagir a diversos eventos de clipe ativados quando o usuário entra ou sai da cena ou interagir com a cena usando o mouse ou o teclado. Por exemplo, você pode carregar uma imagem externa SWF ou JPG no clipe de filme quando o usuário entrar na cena ou permitir que os movimentos do mouse do usuário reposicionem elementos na cena. 6.2.3. Eventos de quadro Em uma timeline principal ou de clipe de filme, um evento de sistema ocorre quando a reprodução entra em um quadro­chave — conhecido como evento de quadro. Os eventos de quadro são úteis para ativar ações baseadas na passagem de tempo (que se movem pela timeline) ou para interagir com elementos visíveis no momento no Stage. Quando você adiciona um script a um quadro­ chave, ele é executado quando o quadro­chave é alcançado durante uma reprodução. Os script anexados a um quadro são chamados scripts de quadro. Uma das utilizações mais comuns dos scripts de quadro é interromper a reprodução quando um determinado quadro­chave é alcançado. Isso é feito com a função stop(). Selecione um quadro­chave e adicione a função stop() como um elemento de script no painel Actions. Ao interromper arquivo SWF em um quadro­chave específico, você precisará executar uma ação. Você pode, por exemplo, usar um script de quadro para atualizar dinamicamente o valor de um rótulo, gerenciar a interação dos elementos no Stage etc.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 33 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática O painel de ações pois duas colunas: a da esquerda e da direita. A parte da esquerda é dividida em duas partes: a parte superior contém todos os actions que pode se aplicar e a parte inferior tem listados os elementos do filme. A coluna da direita contém os actions aplicados ao objeto (exibidos na área branca). Para aplicar um action, basta dar dois cliques sobre o action que se quer aplicar na coluna da direita. Para inserir um link através de uma ação é necessário a seguinte linha de código: on (release) { getURL(" http://www.fema.com.br/index.htm" , " _self" ); } Um link para email fica: on (release) { getURL(" mailto:seuemail@fema.com.br" ); } As ações podem ser aplicadas a símbolos ou diretamente na linha do tempo. Quando se aplica ações a símbolos é necessário definir qual será o evento no símbolo que vai chamar a ação. O Flash é muito mais que um software para criação de animação, ele permite criar interatividade e ações que dão vida à um projeto, na verdade interatividade é um nome restritivo para as ações que você pode criar com o Flash, o melhor seria dar vida ! No Flash existem duas formas de fazerem as coisas acontecerem: quando a animação chega a determinado ponto ou quando há interação do usuário. A interação do usuário se dá através de botões, mas não precisa que o usuário pressione o botão, ele pode ativá­lo simplesmente passando o mouse sobre ele, ou até mesmo pressionando uma tecla qualquer no teclado. A definição de como se dará a interação está no comando Mouse Event. Para ativar as ações de um botão basta que você dê um duplo clique no botão, na janela que irá se abrir escolha a aba "Actions" ou "Ações". Lá você irá ver Quatro botões: Do lado direito um botão de "+" e um de "­" o de "+" serve para incluir uma ação e o de "­" para excluir uma ação. Os comandos simples são: Goto; Play; Stop; Stop all Sounds; Abaixo temos cada um comentado e com suas opções: Comandos básicos Play ­ É um comando sem nenhum parâmetro que inicia a execução de uma animação em Flash; Stop ­ É um comando sem nenhum parâmetro que para a execução de uma animação em Flash;
________________________________________________________ Escola Técnica Machado de Assis Imprensa 34 FEMA – Fundação Educacional Machado de Assis PROGRAMAÇÃO INTERNET II Técnico em Informática Stop all Sounds ­ E um comando sem parâmetro que funciona como um "mute" parando todos os sons de seu filme. Existem soluções melhores para isto, e você verá mais adiante. Goto ­ Este é um comando mais completo que permite um grande controle do filme, os parâmetros usados são: Scene ­ Permite que você desvie sua animação para uma cena específica, o valor padrão é "current scene" (cena atual) e você pode fazer um desvio relativo para a próxima cena "next scene" ou cena anterior "previous scene". A medida que você criar novas cenas elas estarão disponíveis nesta opção também. Frame ­ Permite várias possibilidades como por exemplo: ir para um frame ou label específico, para o frame anterior ou posterior. Control ­ Permite marcar a opção Goto and Play, ou seja, além de ir para o frame especificado acima ainda dá um play na sua animação.
________________________________________________________ Escola Técnica Machado de Assis Imprensa 35 
Download

Técnico em Informática 1