Adequações de Formato de arquivo
para entrega de dados
georreferenciados no sistema de
licenciamento ambiental de Mato
Grosso do Sul
Conversão de arquivos DXF/R12 para
SHAPEFILE utilizando o Sistema de
Informações Geográficas SPRING (gratuito)
Alesandro Copatti – [email protected] 3318-6045
Unidade de Geoprocessamento – GAO – IMASUL
Objetivo

Capacitar consultores para converter um arquivo de
intercâmbio de CAD (DXF/R12) para o formato de SIG,
utilizando um SIG gratuito (SPRING 5.0) a fim de
uniformizar a linguagem de intercâmbio de dados
georreferenciados entre os consultores e o IMASUL,
criando os meios necessários para uma tramitação dos
processos mais ágil e mais criteriosa.
O Sistema de Informações Geográficas
SPRING – Introdução



Licença: gratuito, basta cadastrar e baixar.
Onde encontrar (download da versão 5.0):
http://www.dpi.inpe.br/spring/ (linux e windows)
Como instalar – versão para windows: basta aplicar um
duplo clique sobre o arquivo instala_spr50.exe e
seguir os passos... Para quem não tem familiaridade com
o uso do spring e pretende estudá-lo melhor, sugere-se
instalar o banco de dados com exemplos e o tutorial 10
aulas...
O Sistema de Informações Geográficas
SPRING – criando banco de dados

Criando um Banco de Dados Geográfico (menu Arquivo > Banco de Dados):
Definir o diretório de localização do Banco e clicar CR.
Informar o nome do Banco que será criado (até 32
caracteres).
Escolher o gerenciador do banco (access, dbase,
mysql,...)
Criar e ativar o banco (figura 1)
O Sistema de Informações Geográficas
SPRING – criando um projeto em UTM

Criando um projeto (menu Arquivo -> Projeto):
Definir o nome do projeto
Escolher um sistema de projeção/datum: latlong (geográfica),
SAD 69 (CR e executar).
Definindo o retângulo envolvente – RE*: para MS poderia ser o
seguinte, caso a projeção seja geográfica:
Long1: o 59 0 0.00
long2: o 50 0 0.00
Lat1: s 25 0 0.00
lat2: s 16 0 0.00
* ajustar o RE para os dados do projeto.
Criar e ativar o projeto
O Sistema de Informações Geográficas
SPRING – modelando dados

Criando um modelo de dados para importar o arquivo DXF/R12
(Menu Arquivo -> Modelo de Dados):
Escolher um nome para a(s) categoria(s) onde os dados serão
armazenados.
Definir um modelo para os dados: em nosso caso deverá ser
criada uma categoria do tipo cadastral (pode ser imagem, MNT,
objeto, temático, rede ou não-espacial) e uma categoria de objetos, a
fim de criar atributos para as feições geográficas.
Criar (após criar cada categoria) e executar (após criar todas as
categorias).
Os modelos de dados estarão disponíveis para todos os projetos
criados neste banco de dados.
O Sistema de Informações Geográficas
SPRING – importando os dados em DXF

Importando a layer “Reserva Legal do arquivo DXF/R12 para um PI**:
1 - No menu principal, escolher Arquivo -> Importar...
2 - Clicar no botão Diretório e selecionar o diretório onde está o arquivo DXF/R12; clicar CR
3 - Escolher o formato correspondente: DXF/R12
4 - Selecionar o arquivo onde estão os dados em CAD.
5 - Selecionar a layer correspondente (no exemplo, a Layer Reserva Legal), clicar em
Mostrar conteúdo e Executar (figura 4a)
6 - Escolher a entidade: linha com topologia, ponto 2D, texto,...
7 - Definir unidade: metros, para arquivos de CAD
8 - Definir escala: mantém escala original dos dados.
9 - Definir projeção/Datum e fuso (dos dados!): UTM, SAD 69 e fuso 21 ou 22 (clicar em CR
e executar – figura 4b)
10 - Retângulo Envolvente: mantém o do projeto.
11 - Escolher a categoria cadastral onde os dados serão inseridos (já criada no item anterior
– figura 4c)
12 - Definir um nome para o plano de informação – PI – que será criado e onde os dados
serão inseridos e clicar em executar (figura 4d).
# O SPRING permite importar todas as camadas (layers) para um mesmo PI. Para isso,
repetir os passos de 5 até 12, clicando em mosaico a partir da segunda layer e não alterando o
nome do PI.
# Para importar cada uma das layers para um PI distinto, basta repetir os passos 5 até 12,
alterando o nome do PI.
** Plano de Informação ou view, na linguagem de SIG
O Sistema de Informações Geográficas
SPRING – visualizando as feições linhas
Visualizando as linhas importadas:
No Painel de Controle do SPRING, selecionar o PI de
interesse e clicar na caixa de seleção de linha. Após clicar
em desenhar (figura 5).
O Sistema de Informações Geográficas
SPRING – transformando feições linhas para
polígonos
1- Selecionar o PI que será convertido em polígonos.
2- Clicar no Menu Cadastral -> Edição Vetorial (figura 6a)
3- Na Barra de Ferramentas de Edição Vetorial, clicar nos
Botões “Nós ajustados” e “Nós não Ajustados” (figura 6b)
4-, Nessa Barra, clicar em Ferramentas (seta) -> ajustar
(figura 6c)
5- Novamente clicar em Ferramentas -> poligonizar (figura
6d). * Responder sim para refazer a topologia.
6- Fechar a edição vetorial (figura 6e)
O Sistema de Informações Geográficas
SPRING – Criar atributos para os objetos e
associar o objeto ao polígono
1- Clicar no Menu Editar -> Objetos (figura 7a)
2- Selecionar a categoria onde os objetos serão armazenados.
3- Criar um nome para o objeto. No Exemplo, estamos
“nomeando” o polígono da Reserva Legal. Então o nome
pode ser Reserva Legal (até 32 caracteres!). Clicar em Criar
(figura 7b).
4- Associar o objeto ao polígono. Clicar na operação “associar”
e em entidade (feição) “polígono”.
5- Na tela principal do spring, selecionar o polígono que
deverá estar associado com o objeto recém-criado (figura
7c). Fechar caixa de Diálogo de Objetos.
O Sistema de Informações Geográficas
SPRING – visualizando os objetos criados e
associados.
No Painel de Controle do SPRING, selecionar o PI de
interesse e clicar na caixa de seleção de objetos. Após
clicar em desenhar.
Se tudo correu bem, o polígono ficará com a cor AZUL,
indicando que a associação do polígono com o objeto está
correta.
O Sistema de Informações Geográficas
SPRING – Fazendo o mosaico (merge) dos
polígonos num mesmo plano de informação
Após ajustar, poligonizar, criar e associar os objetos de cada
plano de informação, podemos mosaicar todos os objetos
num mesmo PI.
1- Selecionar o PI correspondente ao perímetro da
propriedade.
2- No menu Principal, clicar em Editar -> Plano de Informação.
3- Mudar o sufixo do arquivo para “_poligonos” e clicar em
“alterar”. Fechar a janela de diálogo. (Figura 8)
4- No Painel de Controle, selecionar o PI renomeado (onde
todos os demais objetos serão inseridos (mosaicados).
5- No menu principal, clicar em Editar -> mosaico...
O Sistema de Informações Geográficas
SPRING – Fazendo o mosaico (merge) dos
polígonos num mesmo plano de informação
6- Na janela de diálogo, selecionar projeto, categoria e PI de
origem dos dados. Eles serão inseridos no PI que foi
selecionado no Painel de Controle. Em “Representações”,
clicar em linhas, polígonos e objetos. Clicar em “mosaico” e
em Executar. Refazer o procedimento para cada um dos PIs
que serão mosaicados.
7 – Para visualizar se os objetos estão corretos no mosaico,
basta ligar os objetos (Painel de Controle) e abrir a tabela
de atributos (clicar em consultar). Na caixa de diálogo que
será aberta, clicar em aplicar. Na tabela de atributos que
será aberta, clicar no título da linha correspondente ao
objeto que será visualizado. Ele aparecerá na tela principal
em verde. Outro clique retira a seleção (figura 9).
O Sistema de Informações Geográficas
SPRING – Exportando o PI em shapefile
12345-
Selecionar o PI que será exportado.
Clicar no Menu Arquivo -> Exportar
Na caixa de Diálogo, selecionar o Formato Shapefile.
Selecionar Coordenadas Geográficas.
Selecionar a categoria onde estão os objetos (todos devem
estar na mesma categoria de objetos)
6- Clicar em salvar e informar um nome para o shape que será
criado (até 32 caracteres). (Figura 10)
Testando o shapefile criado com SPRING no SISLA
1- Com o navegador Mozila Firefox (licença livre,
multiplataforma), acessar o endereço
http://sisla.imasul.ms.gov.br/sislaConsultor
2- Clicar na Guia “Adiciona”;
3- Clicar no Botão de “UpLoad de arquivo shape” (figura 11) e
indicar a localização dos arquivos com as extensões *.shp,
*.shx e *.dbf, respectivamente (figura 11a).
4- Selecionar a projeção/Datum e clicar no botão “carregar”
5 – Se o shapefile não tiver nenhum problema, serão
carregados os polígonos do shape e aparecerá a
mensagem de gerado gerado com sucesso (figura 11b).
Clicando no link aparecerá o relatório em tela (figura 11c).
Clicando em Imprimir PDF será gerado o relatório digital em
PDF, que poderá ser anexado no processo. (figura 11d).
Fim
Download

TUTORIAL_conversaoDXFr12paraSHAPE_SPRING